Hybrid Brick (possible jtag bug)

This is JTAG to debrick any JTAG device. Modem, cable boxes, dish boxes routers.
cranckyme
Posts: 2
Joined: Tue May 03, 2016 11:19 am

Hybrid Brick (possible jtag bug)

Post by cranckyme » Wed May 04, 2016 8:37 pm

so I've been writing to the SBV6220 for a good while now and all of a sudden, each time i write to the modem, it's bricked!! (all lights on after a successful write/verify). what's going on... I've written to this SPI chip 100's of times and now it will not boot. i had a second SBV6220 as backup laying around so i wrote an original 16M to that and same issue. this started to happen about 2 days ago and im all out of ideas as to what the problem is. i develop my own firmware so im constantly writing to the chip. i use the ISP pin method primarily and tried the external 5V method and both write/verify successfully but the modem will not boot up. (stuck with all lights on)
it's as if the jtag's telling me it's writing in one spot and writing somewhere else because
if it were writing where it should, the device would boot up as it should. I'm running 0.77 jtag software. i've tried writing at all speeds and same thing. and yes it detects the chip correctly.

any help is greatly appreciated.

thanks

ricktendo
Posts: 134
Joined: Sat Nov 29, 2014 12:41 pm

Post by ricktendo » Thu May 05, 2016 5:55 am

May not make a difference but try updating the software to 0.78

usbbdm
Posts: 8628
Joined: Mon Jul 18, 2005 9:33 pm

Post by usbbdm » Thu May 05, 2016 8:01 am

It must not be the bug of the software. You can try to replace the flash chip with a "good one" and I am sure it is the same result.
If you have the access of the serial port, it might be able to tell more what is going on. Having all LED on tells very little about the health of the modem.

cranckyme
Posts: 2
Joined: Tue May 03, 2016 11:19 am

Post by cranckyme » Wed Jun 15, 2016 3:57 pm

after connecting to the serial port, i realized it was hanging on newly implemented code.
moved the code to other location and all is well.

Post Reply